0

no odometer, no speed indication, automatic shutdown

Aug 26, 2020 - 9:49 AM

Viewed 881 times

  • Gol:
    OK, so after the test drive, the bike works fine, except for the lights issue.
    I was surprised, like others, that it seems to work on an all or nothing basis until 25km/h and with very subtle (if any) difference between the 1-5 assist modes. But I guess this is an issue of the type of assist rather than a defect.
    @satyasekhar Did unplugging (after cutting the ties) and plugging back solve your problem?

    @gol. Yes it did resolve the problem. Now I can see that my speedometer started working. Thanks a lot @gol and @cjm1066 . I didn’t cut the ties, I just unplugged and plugged it again 🙂

    But the battery power percentage on the display is still not accurate.

    By the way, AMX bikes are pedelecs so I believe it doesn’t matter whether the assist level is at level 1 or at level 5. Rider has to apply strength then the bike will catch 25 kms even at level 1 and being on level 5 requires less strength from a rider.

    This post was edited Sep 15, 2020 09:49PM
    0
  • @gol - Ha great that you are now up and running. Lights issue -- a few others have that and I have been investigating. A solution is on its way I think.

    0
  • I have the same issue with my speedometer and odometer not working, but the assistance and power selector does. I have tried unplugging the cable to the motor, but its still not working - any other ideas???

    0
  • Leo,
    Did you cut the ties before pluging back ? When I had the problem, I had the impression it was pluged all the way, but the ties prevented the cable to be loose enough for that.
    I hope it works....

    0
  • I did cut the ties. I’ve been away this week, but will give it another go.

    0